Supro 24 With One Power Tube Not Working

Forum to discuss amp circuits besides the 18 Watters and their ilk.

Moderators: JMPGuitars, CurtissRobin, colossal, zaphod_phil, Daviedawg, Graydon

Post Reply
User avatar
rags
Unrated
Posts: 13
Joined: Mon 03/15/10 2:00 am
Location: Michigan

Supro 24 With One Power Tube Not Working

Post by rags »

Hi Forum,
I build this Supro 24 a while ago. I recently picked it up at the store that was selling it. I've got only one of the 6972 power tubes showing a glow. I checked voltages and I'm measuring very high voltages into the preamp section. About 350V DC. this is almost double what should be in the preamp section for the three 12AX7 tubes. The heater voltages measure 3.5 V AC and I do get voltage on the Output Transformer going to the two 6972 power tubes. The amp hums but doesn't do anything. It was running fine after startup for several months. I tried changing out the power tubes and they performed the same. Only one tube was showing a glow.
Could I have a blown Output Transformer??
Is there something else I should look for??
Thanks
Rags
0 x

User avatar
rags
Unrated
Posts: 13
Joined: Mon 03/15/10 2:00 am
Location: Michigan

Re: Supro 24 With One Power Tube Not Working

Post by rags »

Ok, here's an update.
I was messing around changing out tubes and when I went back to the 5Y3 rectifier that was in the amp. It suddenly fired up both power tubes and ran beautifully. But, I'm still concerned that I've got a problem.
I can send voltages before and after if that helps.
At least I know that most of the circuit is working well.
Could it be a bad rectifier tube?
Maybe a cold joint where the power tube is hooked up??
Any advice is appreciated.
Thanks
Rags
0 x

Daviedawg
Superior Amp Tech
Superior Amp Tech
Posts: 616
Joined: Fri 01/08/10 2:00 am
Location: Scotland

Re: Supro 24 With One Power Tube Not Working

Post by Daviedawg »

It could also be something as simple as a dirty pin in one of the valve sockets. It's hard to diagnose an intermittent until it happens again.

But certainly try a bit of chopsticking around the valve bases to look for a noisy joint. That is most often the cause of intemittents. As I know from hours of fun chasing them.

If that shows no joy, then take the voltages to see if that gives any indicators.

Dd
1 x

User avatar
rags
Unrated
Posts: 13
Joined: Mon 03/15/10 2:00 am
Location: Michigan

Re: Supro 24 With One Power Tube Not Working

Post by rags »

Thanks Dd, Will do
0 x

Post Reply