Gregory 22a

Forum to discuss amp circuits besides the 18 Watters and their ilk.

Moderators: JMPGuitars, CurtissRobin, colossal, zaphod_phil, Daviedawg, Graydon

Post Reply
J-Turn
Unrated
Posts: 3
Joined: Mon 03/02/20 6:59 pm

Gregory 22a

Post by J-Turn »

Hi, I’m new to the board and I hope I’m posting this in the right place. I was wondering if anyone has any experience with this amp. I recently got one that was working but poorly. I changed the filter caps and a few drifted resistors and got it going/sounding quite good. Swapping 12ax7’s of different brands made a big difference in the trem and reverb so I decided to try different EL84s. I put in a set and one of them didn’t light up. Turned the amp off pulled the non glowing tube and put in one The was working moments before. Turned it on, no sound. Put in the 2 EL84s that we’re working fine moments before and still no sound. Next I put in a new set of JJ’s I got sound for like 5 seconds and it faded to nothing. No smells nothing looks burnt. Any ideas?
0 x

geoff 1965
Frequent poster
Frequent poster
Posts: 748
Joined: Mon 01/04/16 3:52 pm

Re: Gregory 22a

Post by geoff 1965 »

i've found this schematic for the 22a,can you post some good close up pics of the internals,it helps as sometimes people can spot something.
Mark 22a schematic.jpg
You do not have the required permissions to view the files attached to this post.
0 x

J-Turn
Unrated
Posts: 3
Joined: Mon 03/02/20 6:59 pm

Re: Gregory 22a

Post by J-Turn »

Image
You do not have the required permissions to view the files attached to this post.
0 x

J-Turn
Unrated
Posts: 3
Joined: Mon 03/02/20 6:59 pm

Re: Gregory 22a

Post by J-Turn »

Found it! I cooked the resistor on the filter caps. Works again!
2 x

Post Reply