Blown PT?

18watt-specific Tech Talk - Building, Fixing, Parts, Mods...

Moderators: CurtissRobin, Daviedawg, Graydon, zaphod_phil, rock_mumbles

geoff 1965
Occasional poster
Occasional poster
Posts: 487
Joined: Mon 01/04/16 3:52 pm

Re: Blown PT?

Postby geoff 1965 » Sat 06/08/19 10:29 am

i built my amp to the lite2b spec initially and it has always been very quiet with no hum or hiss,what type of resistors have you used on the input jacks?
if you add some more pics of your jack's,pots,grounding etc someone might spot something.
0 x

Riffmonster
Unrated
Posts: 22
Joined: Tue 02/09/16 12:38 pm

Re: Blown PT?

Postby Riffmonster » Sat 06/08/19 5:17 pm

Hi Geoff,

here are two pictures. I already tried separating the ground point of the pre amp from the power amp but it did not change the problem. Also, the shielded looking wire is not a real shielded wire but a desperate attempt of wrapping a normal wire in aluminium. I should buy some shielded wire.
I still can not find the problem. It is maybe just poor leaddres. I should have taken more time to build it.

Cheers
You do not have the required permissions to view the files attached to this post.
0 x

geoff 1965
Occasional poster
Occasional poster
Posts: 487
Joined: Mon 01/04/16 3:52 pm

Re: Blown PT?

Postby geoff 1965 » Wed 06/12/19 1:46 pm

if you fit shielded wire to the input you could also use a small value grid stopper 10 to 15K which will help with interference but won't affect the signal.
you've used good quality components and you have a lot of room for future mods if needed.there as been a lot of posts recently regarding grounding so have a browse through them.
good luck
0 x

User avatar
JMPGuitars
Super Duper Admin
Super Duper Admin
Posts: 1211
Joined: Tue 09/18/12 8:00 pm
Location: South Central, MA
Contact:

Re: Blown PT?

Postby JMPGuitars » Wed 06/12/19 2:52 pm

Ground schemes: viewtopic.php?f=4&t=25372

Solder technique: viewtopic.php?f=4&t=25396
0 x
'I installed a skylight in my apartment yesterday... The people who live above me are furious.' - Steven Wright
Web Design - DolceVittoria.com
Guitars / Amps / Effects - JMPGuitars.com

Riffmonster
Unrated
Posts: 22
Joined: Tue 02/09/16 12:38 pm

Re: Blown PT?

Postby Riffmonster » Thu 06/13/19 5:22 am

Thanks for the replies guys!
I reworked most of my solder joints and used real shielded wire but still there is no difference. I will try the 10k gridstoppers now.
I noticed that when I turn the tone pot all the way to the right, the buzz gets much more. The flaw must be before the control then, right?

Cheers!
0 x

User avatar
JMPGuitars
Super Duper Admin
Super Duper Admin
Posts: 1211
Joined: Tue 09/18/12 8:00 pm
Location: South Central, MA
Contact:

Re: Blown PT?

Postby JMPGuitars » Thu 06/13/19 6:57 am

Post some updated photos. Check your voltages and post them too.
0 x
'I installed a skylight in my apartment yesterday... The people who live above me are furious.' - Steven Wright
Web Design - DolceVittoria.com
Guitars / Amps / Effects - JMPGuitars.com

Riffmonster
Unrated
Posts: 22
Joined: Tue 02/09/16 12:38 pm

Re: Blown PT?

Postby Riffmonster » Thu 06/13/19 8:51 am

I was about to measure the voltages. Plates on V1 are about 130V and Plates of the El84 about 352V. Screens of the EL84 around 330V. When I try to measure the plate voltages of the phase inverter, a loud pop appears once I touch the pin with my probe. I can not really measure the voltages there.
:?
The pictures are from yesterday without the shielded wire and without the grid stopper.
You do not have the required permissions to view the files attached to this post.
0 x

geoff 1965
Occasional poster
Occasional poster
Posts: 487
Joined: Mon 01/04/16 3:52 pm

Re: Blown PT?

Postby geoff 1965 » Thu 06/13/19 9:38 am

if you make a dummy load for the speaker jack you can test all the voltages safely without damaging your output transformer.
001.JPG
this one is 100watt 8ohm wirewound.
You do not have the required permissions to view the files attached to this post.
1 x

Riffmonster
Unrated
Posts: 22
Joined: Tue 02/09/16 12:38 pm

Re: Blown PT?

Postby Riffmonster » Thu 06/13/19 10:37 am

That’s true, I forgot about using a dummy load. I actually have one at home and will post the last voltages after work.
0 x

Riffmonster
Unrated
Posts: 22
Joined: Tue 02/09/16 12:38 pm

Re: Blown PT?

Postby Riffmonster » Fri 06/14/19 9:08 am

So I have 226V at the plates and 36V at the grids and 69 at the cathodes of the phase inverter. The 36V seems a bit low, given 20% tolerance. Cathodes of the El84 is 10V
0 x

geoff 1965
Occasional poster
Occasional poster
Posts: 487
Joined: Mon 01/04/16 3:52 pm

Re: Blown PT?

Postby geoff 1965 » Fri 06/14/19 9:53 am

regarding grounding,my lite2 is a cage layout with the valves at the front so is a different layout to yours but here's the difference with the grounding; i have the input jack and tone pots grounded seperately from the B+, phase inverter ground. also my el84 bias is grounded seperately,you might want to try this and see if it helps.this is the layout i worked from with some ammendments to grounding.
18W_LITE2B_LAYOUT_BrownNote_TRANS_FINAL_v1.1.jpg
what value bias resistor for the el84's have you used?
You do not have the required permissions to view the files attached to this post.
0 x

Riffmonster
Unrated
Posts: 22
Joined: Tue 02/09/16 12:38 pm

Re: Blown PT?

Postby Riffmonster » Fri 06/14/19 10:09 am

Thanks for the input! I will probably try out the different ground and see if it helps.
I have a 150R resistor with a 47uf cap.
0 x

Daviedawg
Superior Amp Tech
Superior Amp Tech
Posts: 496
Joined: Fri 01/08/10 2:00 am
Location: Scotland

Re: Blown PT?

Postby Daviedawg » Sat 06/15/19 2:08 am

Your voltages seem a bit awry. On the power valves you should have a target of 12v on the cathodes and a difference a little less than that between pins 7 and 9 plate and screen. Can you post a full list of your voltages? Or you can refer to the standard examples posted in the downloads for a comparison, bearing in mind that they are for a traditional 18 watt. Then go from there.

Dd
1 x

Riffmonster
Unrated
Posts: 22
Joined: Tue 02/09/16 12:38 pm

Re: Blown PT?

Postby Riffmonster » Wed 06/19/19 2:31 pm

Hey Dd,

sorry for the late reply. Here are my voltages:

V1:

Pin 1: 149
Pin 6:149

V2
Pin 1: 234
Pin 6: 230
Pin 3: 78
Pin 8 :78
Pin 2: 38
Pin 7: 37

EL 84s

Pin 7: 340
Pin 9: 323
Pin 3: 10

To me they seem not too weird, but I might be wrong.
0 x

Daviedawg
Superior Amp Tech
Superior Amp Tech
Posts: 496
Joined: Fri 01/08/10 2:00 am
Location: Scotland

Re: Blown PT?

Postby Daviedawg » Thu 06/20/19 2:11 am

Seeing them all together I agree that there is no reason to think that they are causing any issue.
Just as an aside. For best tone I would adjust your power valve cathode resistor to get the cathode readings up from 10v to as close to 12v as possible. It really is a noticeable difference. Try a 125 ohm.

Dd
0 x


Return to “18watt Technical Discussion”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest